Calamares - distribution indipendent installer
Du kan inte välja fler än 25 ämnen Ämnen måste starta med en bokstav eller siffra, kan innehålla bindestreck ('-') och vara max 35 tecken långa.
Alf Gaida 41e04dc1d6 Update upstream source from tag 'upstream/3.2.15' 1 år sedan
3rdparty New upstream version 3.2.15 1 år sedan
CMakeModules New upstream version 3.2.15 1 år sedan
LICENSES New upstream version 3.2.15 1 år sedan
ci New upstream version 3.2.15 1 år sedan
data New upstream version 3.2.15 1 år sedan
debian Some changes for new version 1 år sedan
lang New upstream version 3.2.15 1 år sedan
man New snapshot: 3.2.2v3.2.2-1 2 år sedan
src New upstream version 3.2.15 1 år sedan
.clang-format New upstream version 3.2.15 1 år sedan
AUTHORS Upstream release v3.2.9 1 år sedan
CHANGES New upstream version 3.2.15 1 år sedan
CMakeLists.txt New upstream version 3.2.15 1 år sedan
CalamaresBuildTreeSettings.cmake.in New snapshot: 3.2.2v3.2.2-1 2 år sedan
CalamaresConfig.cmake.in New snapshot: 3.2.2v3.2.2-1 2 år sedan
CalamaresConfigVersion.cmake.in New snapshot: 3.2.2v3.2.2-1 2 år sedan
CalamaresUse.cmake.in New snapshot: 3.2.2v3.2.2-1 2 år sedan
Dockerfile New snapshot: 3.2.2v3.2.2-1 2 år sedan
LICENSE New snapshot: 3.2.2v3.2.2-1 2 år sedan
README.md New upstream version 3.2.15 1 år sedan
calamares.desktop New upstream version 3.2.15 1 år sedan
calamares.desktop.in New upstream version 3.2.15 1 år sedan
cmake_uninstall.cmake.in New snapshot: 3.2.2v3.2.2-1 2 år sedan
com.github.calamares.calamares.policy New snapshot: 3.2.2v3.2.2-1 2 år sedan
io.calamares.calamares.appdata.xml New upstream version 3.2.15 1 år sedan
settings.conf Upstream release v3.2.9 1 år sedan

README.md

Calamares: Distribution-Independent Installer Framework


GitHub release Build Status Travis Build Status Coverity Scan Build Status GitHub license

Report a Bug Contribute Translate Freenode (IRC): #calamares Wiki

Dependencies

Main:

  • Compiler with C++14 support: GCC >= 5 or Clang >= 3.5.1
  • CMake >= 3.3
  • Qt >= 5.9
  • yaml-cpp >= 0.5.1
  • Python >= 3.3 (required for some modules)
  • Boost.Python >= 1.55.0 (required for some modules)
  • KDE extra-cmake-modules >= 5.18 (recommended; required for some modules; required for some tests)
  • KDE Frameworks KCoreAddons (>= 5.58 recommended)
  • PythonQt (optional, deprecated)

Modules:

  • Individual modules may have their own requirements; these are listed in CMake output. Particular requirements (not complete):
  • fsresizer KPMCore >= 3.3
  • partition KPMCore >= 3.3
  • users LibPWQuality (optional)

Building

See wiki for up to date building and deployment instructions.