Calamares - distribution indipendent installer
Вы не можете выбрать более 25 тем Темы должны начинаться с буквы или цифры, могут содержать дефисы(-) и должны содержать не более 35 символов.
Alf Gaida 41e04dc1d6 Update upstream source from tag 'upstream/3.2.15' 1 год назад
3rdparty New upstream version 3.2.15 1 год назад
CMakeModules New upstream version 3.2.15 1 год назад
LICENSES New upstream version 3.2.15 1 год назад
ci New upstream version 3.2.15 1 год назад
data New upstream version 3.2.15 1 год назад
debian Some changes for new version 1 год назад
lang New upstream version 3.2.15 1 год назад
man New snapshot: 3.2.2v3.2.2-1 2 лет назад
src New upstream version 3.2.15 1 год назад
.clang-format New upstream version 3.2.15 1 год назад
AUTHORS Upstream release v3.2.9 1 год назад
CHANGES New upstream version 3.2.15 1 год назад
CMakeLists.txt New upstream version 3.2.15 1 год назад
CalamaresBuildTreeSettings.cmake.in New snapshot: 3.2.2v3.2.2-1 2 лет назад
CalamaresConfig.cmake.in New snapshot: 3.2.2v3.2.2-1 2 лет назад
CalamaresConfigVersion.cmake.in New snapshot: 3.2.2v3.2.2-1 2 лет назад
CalamaresUse.cmake.in New snapshot: 3.2.2v3.2.2-1 2 лет назад
Dockerfile New snapshot: 3.2.2v3.2.2-1 2 лет назад
LICENSE New snapshot: 3.2.2v3.2.2-1 2 лет назад
README.md New upstream version 3.2.15 1 год назад
calamares.desktop New upstream version 3.2.15 1 год назад
calamares.desktop.in New upstream version 3.2.15 1 год назад
cmake_uninstall.cmake.in New snapshot: 3.2.2v3.2.2-1 2 лет назад
com.github.calamares.calamares.policy New snapshot: 3.2.2v3.2.2-1 2 лет назад
io.calamares.calamares.appdata.xml New upstream version 3.2.15 1 год назад
settings.conf Upstream release v3.2.9 1 год назад

README.md

Calamares: Distribution-Independent Installer Framework


GitHub release Build Status Travis Build Status Coverity Scan Build Status GitHub license

Report a Bug Contribute Translate Freenode (IRC): #calamares Wiki

Dependencies

Main:

  • Compiler with C++14 support: GCC >= 5 or Clang >= 3.5.1
  • CMake >= 3.3
  • Qt >= 5.9
  • yaml-cpp >= 0.5.1
  • Python >= 3.3 (required for some modules)
  • Boost.Python >= 1.55.0 (required for some modules)
  • KDE extra-cmake-modules >= 5.18 (recommended; required for some modules; required for some tests)
  • KDE Frameworks KCoreAddons (>= 5.58 recommended)
  • PythonQt (optional, deprecated)

Modules:

  • Individual modules may have their own requirements; these are listed in CMake output. Particular requirements (not complete):
  • fsresizer KPMCore >= 3.3
  • partition KPMCore >= 3.3
  • users LibPWQuality (optional)

Building

See wiki for up to date building and deployment instructions.