Calamares - distribution indipendent installer
Você não pode selecionar mais de 25 tópicos Os tópicos devem começar com uma letra ou um número, podem incluir traços ('-') e podem ter até 35 caracteres.
Alf Gaida 41e04dc1d6 Update upstream source from tag 'upstream/3.2.15' 1 ano atrás
3rdparty New upstream version 3.2.15 1 ano atrás
CMakeModules New upstream version 3.2.15 1 ano atrás
LICENSES New upstream version 3.2.15 1 ano atrás
ci New upstream version 3.2.15 1 ano atrás
data New upstream version 3.2.15 1 ano atrás
debian Some changes for new version 1 ano atrás
lang New upstream version 3.2.15 1 ano atrás
man New snapshot: 3.2.2v3.2.2-1 2 anos atrás
src New upstream version 3.2.15 1 ano atrás
.clang-format New upstream version 3.2.15 1 ano atrás
AUTHORS Upstream release v3.2.9 1 ano atrás
CHANGES New upstream version 3.2.15 1 ano atrás
CMakeLists.txt New upstream version 3.2.15 1 ano atrás
CalamaresBuildTreeSettings.cmake.in New snapshot: 3.2.2v3.2.2-1 2 anos atrás
CalamaresConfig.cmake.in New snapshot: 3.2.2v3.2.2-1 2 anos atrás
CalamaresConfigVersion.cmake.in New snapshot: 3.2.2v3.2.2-1 2 anos atrás
CalamaresUse.cmake.in New snapshot: 3.2.2v3.2.2-1 2 anos atrás
Dockerfile New snapshot: 3.2.2v3.2.2-1 2 anos atrás
LICENSE New snapshot: 3.2.2v3.2.2-1 2 anos atrás
README.md New upstream version 3.2.15 1 ano atrás
calamares.desktop New upstream version 3.2.15 1 ano atrás
calamares.desktop.in New upstream version 3.2.15 1 ano atrás
cmake_uninstall.cmake.in New snapshot: 3.2.2v3.2.2-1 2 anos atrás
com.github.calamares.calamares.policy New snapshot: 3.2.2v3.2.2-1 2 anos atrás
io.calamares.calamares.appdata.xml New upstream version 3.2.15 1 ano atrás
settings.conf Upstream release v3.2.9 1 ano atrás

README.md

Calamares: Distribution-Independent Installer Framework


GitHub release Build Status Travis Build Status Coverity Scan Build Status GitHub license

Report a Bug Contribute Translate Freenode (IRC): #calamares Wiki

Dependencies

Main:

  • Compiler with C++14 support: GCC >= 5 or Clang >= 3.5.1
  • CMake >= 3.3
  • Qt >= 5.9
  • yaml-cpp >= 0.5.1
  • Python >= 3.3 (required for some modules)
  • Boost.Python >= 1.55.0 (required for some modules)
  • KDE extra-cmake-modules >= 5.18 (recommended; required for some modules; required for some tests)
  • KDE Frameworks KCoreAddons (>= 5.58 recommended)
  • PythonQt (optional, deprecated)

Modules:

  • Individual modules may have their own requirements; these are listed in CMake output. Particular requirements (not complete):
  • fsresizer KPMCore >= 3.3
  • partition KPMCore >= 3.3
  • users LibPWQuality (optional)

Building

See wiki for up to date building and deployment instructions.