Calamares - distribution indipendent installer
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
Alf Gaida 41e04dc1d6 Update upstream source from tag 'upstream/3.2.15' 1 rok temu
3rdparty New upstream version 3.2.15 1 rok temu
CMakeModules New upstream version 3.2.15 1 rok temu
LICENSES New upstream version 3.2.15 1 rok temu
ci New upstream version 3.2.15 1 rok temu
data New upstream version 3.2.15 1 rok temu
debian Some changes for new version 1 rok temu
lang New upstream version 3.2.15 1 rok temu
man New snapshot: 3.2.2v3.2.2-1 2 lat temu
src New upstream version 3.2.15 1 rok temu
.clang-format New upstream version 3.2.15 1 rok temu
AUTHORS Upstream release v3.2.9 1 rok temu
CHANGES New upstream version 3.2.15 1 rok temu
CMakeLists.txt New upstream version 3.2.15 1 rok temu
CalamaresBuildTreeSettings.cmake.in New snapshot: 3.2.2v3.2.2-1 2 lat temu
CalamaresConfig.cmake.in New snapshot: 3.2.2v3.2.2-1 2 lat temu
CalamaresConfigVersion.cmake.in New snapshot: 3.2.2v3.2.2-1 2 lat temu
CalamaresUse.cmake.in New snapshot: 3.2.2v3.2.2-1 2 lat temu
Dockerfile New snapshot: 3.2.2v3.2.2-1 2 lat temu
LICENSE New snapshot: 3.2.2v3.2.2-1 2 lat temu
README.md New upstream version 3.2.15 1 rok temu
calamares.desktop New upstream version 3.2.15 1 rok temu
calamares.desktop.in New upstream version 3.2.15 1 rok temu
cmake_uninstall.cmake.in New snapshot: 3.2.2v3.2.2-1 2 lat temu
com.github.calamares.calamares.policy New snapshot: 3.2.2v3.2.2-1 2 lat temu
io.calamares.calamares.appdata.xml New upstream version 3.2.15 1 rok temu
settings.conf Upstream release v3.2.9 1 rok temu

README.md

Calamares: Distribution-Independent Installer Framework


GitHub release Build Status Travis Build Status Coverity Scan Build Status GitHub license

Report a Bug Contribute Translate Freenode (IRC): #calamares Wiki

Dependencies

Main:

  • Compiler with C++14 support: GCC >= 5 or Clang >= 3.5.1
  • CMake >= 3.3
  • Qt >= 5.9
  • yaml-cpp >= 0.5.1
  • Python >= 3.3 (required for some modules)
  • Boost.Python >= 1.55.0 (required for some modules)
  • KDE extra-cmake-modules >= 5.18 (recommended; required for some modules; required for some tests)
  • KDE Frameworks KCoreAddons (>= 5.58 recommended)
  • PythonQt (optional, deprecated)

Modules:

  • Individual modules may have their own requirements; these are listed in CMake output. Particular requirements (not complete):
  • fsresizer KPMCore >= 3.3
  • partition KPMCore >= 3.3
  • users LibPWQuality (optional)

Building

See wiki for up to date building and deployment instructions.