Calamares - distribution indipendent installer
Nevar pievienot vairāk kā 25 tēmas Tēmai ir jāsākas ar burtu vai ciparu, tā var saturēt domu zīmes ('-') un var būt līdz 35 simboliem gara.
Alf Gaida 41e04dc1d6 Update upstream source from tag 'upstream/3.2.15' pirms 1 gada
3rdparty New upstream version 3.2.15 pirms 1 gada
CMakeModules New upstream version 3.2.15 pirms 1 gada
LICENSES New upstream version 3.2.15 pirms 1 gada
ci New upstream version 3.2.15 pirms 1 gada
data New upstream version 3.2.15 pirms 1 gada
debian Some changes for new version pirms 1 gada
lang New upstream version 3.2.15 pirms 1 gada
man New snapshot: 3.2.2v3.2.2-1 pirms 2 gadiem
src New upstream version 3.2.15 pirms 1 gada
.clang-format New upstream version 3.2.15 pirms 1 gada
AUTHORS Upstream release v3.2.9 pirms 1 gada
CHANGES New upstream version 3.2.15 pirms 1 gada
CMakeLists.txt New upstream version 3.2.15 pirms 1 gada
CalamaresBuildTreeSettings.cmake.in New snapshot: 3.2.2v3.2.2-1 pirms 2 gadiem
CalamaresConfig.cmake.in New snapshot: 3.2.2v3.2.2-1 pirms 2 gadiem
CalamaresConfigVersion.cmake.in New snapshot: 3.2.2v3.2.2-1 pirms 2 gadiem
CalamaresUse.cmake.in New snapshot: 3.2.2v3.2.2-1 pirms 2 gadiem
Dockerfile New snapshot: 3.2.2v3.2.2-1 pirms 2 gadiem
LICENSE New snapshot: 3.2.2v3.2.2-1 pirms 2 gadiem
README.md New upstream version 3.2.15 pirms 1 gada
calamares.desktop New upstream version 3.2.15 pirms 1 gada
calamares.desktop.in New upstream version 3.2.15 pirms 1 gada
cmake_uninstall.cmake.in New snapshot: 3.2.2v3.2.2-1 pirms 2 gadiem
com.github.calamares.calamares.policy New snapshot: 3.2.2v3.2.2-1 pirms 2 gadiem
io.calamares.calamares.appdata.xml New upstream version 3.2.15 pirms 1 gada
settings.conf Upstream release v3.2.9 pirms 1 gada

README.md

Calamares: Distribution-Independent Installer Framework


GitHub release Build Status Travis Build Status Coverity Scan Build Status GitHub license

Report a Bug Contribute Translate Freenode (IRC): #calamares Wiki

Dependencies

Main:

  • Compiler with C++14 support: GCC >= 5 or Clang >= 3.5.1
  • CMake >= 3.3
  • Qt >= 5.9
  • yaml-cpp >= 0.5.1
  • Python >= 3.3 (required for some modules)
  • Boost.Python >= 1.55.0 (required for some modules)
  • KDE extra-cmake-modules >= 5.18 (recommended; required for some modules; required for some tests)
  • KDE Frameworks KCoreAddons (>= 5.58 recommended)
  • PythonQt (optional, deprecated)

Modules:

  • Individual modules may have their own requirements; these are listed in CMake output. Particular requirements (not complete):
  • fsresizer KPMCore >= 3.3
  • partition KPMCore >= 3.3
  • users LibPWQuality (optional)

Building

See wiki for up to date building and deployment instructions.