Calamares - distribution indipendent installer
Du kannst nicht mehr als 25 Themen auswählen Themen müssen mit entweder einem Buchstaben oder einer Ziffer beginnen. Sie können Bindestriche („-“) enthalten und bis zu 35 Zeichen lang sein.
Alf Gaida 41e04dc1d6 Update upstream source from tag 'upstream/3.2.15' vor 1 Jahr
3rdparty New upstream version 3.2.15 vor 1 Jahr
CMakeModules New upstream version 3.2.15 vor 1 Jahr
LICENSES New upstream version 3.2.15 vor 1 Jahr
ci New upstream version 3.2.15 vor 1 Jahr
data New upstream version 3.2.15 vor 1 Jahr
debian Some changes for new version vor 1 Jahr
lang New upstream version 3.2.15 vor 1 Jahr
man New snapshot: 3.2.2v3.2.2-1 vor 2 Jahren
src New upstream version 3.2.15 vor 1 Jahr
.clang-format New upstream version 3.2.15 vor 1 Jahr
AUTHORS Upstream release v3.2.9 vor 1 Jahr
CHANGES New upstream version 3.2.15 vor 1 Jahr
CMakeLists.txt New upstream version 3.2.15 vor 1 Jahr
CalamaresBuildTreeSettings.cmake.in New snapshot: 3.2.2v3.2.2-1 vor 2 Jahren
CalamaresConfig.cmake.in New snapshot: 3.2.2v3.2.2-1 vor 2 Jahren
CalamaresConfigVersion.cmake.in New snapshot: 3.2.2v3.2.2-1 vor 2 Jahren
CalamaresUse.cmake.in New snapshot: 3.2.2v3.2.2-1 vor 2 Jahren
Dockerfile New snapshot: 3.2.2v3.2.2-1 vor 2 Jahren
LICENSE New snapshot: 3.2.2v3.2.2-1 vor 2 Jahren
README.md New upstream version 3.2.15 vor 1 Jahr
calamares.desktop New upstream version 3.2.15 vor 1 Jahr
calamares.desktop.in New upstream version 3.2.15 vor 1 Jahr
cmake_uninstall.cmake.in New snapshot: 3.2.2v3.2.2-1 vor 2 Jahren
com.github.calamares.calamares.policy New snapshot: 3.2.2v3.2.2-1 vor 2 Jahren
io.calamares.calamares.appdata.xml New upstream version 3.2.15 vor 1 Jahr
settings.conf Upstream release v3.2.9 vor 1 Jahr

README.md

Calamares: Distribution-Independent Installer Framework


GitHub release Build Status Travis Build Status Coverity Scan Build Status GitHub license

Report a Bug Contribute Translate Freenode (IRC): #calamares Wiki

Dependencies

Main:

  • Compiler with C++14 support: GCC >= 5 or Clang >= 3.5.1
  • CMake >= 3.3
  • Qt >= 5.9
  • yaml-cpp >= 0.5.1
  • Python >= 3.3 (required for some modules)
  • Boost.Python >= 1.55.0 (required for some modules)
  • KDE extra-cmake-modules >= 5.18 (recommended; required for some modules; required for some tests)
  • KDE Frameworks KCoreAddons (>= 5.58 recommended)
  • PythonQt (optional, deprecated)

Modules:

  • Individual modules may have their own requirements; these are listed in CMake output. Particular requirements (not complete):
  • fsresizer KPMCore >= 3.3
  • partition KPMCore >= 3.3
  • users LibPWQuality (optional)

Building

See wiki for up to date building and deployment instructions.