Calamares - distribution indipendent installer
Nelze vybrat více než 25 témat Téma musí začínat písmenem nebo číslem, může obsahovat pomlčky („-“) a může být dlouhé až 35 znaků.
Alf Gaida 41e04dc1d6 Update upstream source from tag 'upstream/3.2.15' před 1 rokem
3rdparty New upstream version 3.2.15 před 1 rokem
CMakeModules New upstream version 3.2.15 před 1 rokem
LICENSES New upstream version 3.2.15 před 1 rokem
ci New upstream version 3.2.15 před 1 rokem
data New upstream version 3.2.15 před 1 rokem
debian Some changes for new version před 1 rokem
lang New upstream version 3.2.15 před 1 rokem
man New snapshot: 3.2.2v3.2.2-1 před 2 roky
src New upstream version 3.2.15 před 1 rokem
.clang-format New upstream version 3.2.15 před 1 rokem
AUTHORS Upstream release v3.2.9 před 1 rokem
CHANGES New upstream version 3.2.15 před 1 rokem
CMakeLists.txt New upstream version 3.2.15 před 1 rokem
CalamaresBuildTreeSettings.cmake.in New snapshot: 3.2.2v3.2.2-1 před 2 roky
CalamaresConfig.cmake.in New snapshot: 3.2.2v3.2.2-1 před 2 roky
CalamaresConfigVersion.cmake.in New snapshot: 3.2.2v3.2.2-1 před 2 roky
CalamaresUse.cmake.in New snapshot: 3.2.2v3.2.2-1 před 2 roky
Dockerfile New snapshot: 3.2.2v3.2.2-1 před 2 roky
LICENSE New snapshot: 3.2.2v3.2.2-1 před 2 roky
README.md New upstream version 3.2.15 před 1 rokem
calamares.desktop New upstream version 3.2.15 před 1 rokem
calamares.desktop.in New upstream version 3.2.15 před 1 rokem
cmake_uninstall.cmake.in New snapshot: 3.2.2v3.2.2-1 před 2 roky
com.github.calamares.calamares.policy New snapshot: 3.2.2v3.2.2-1 před 2 roky
io.calamares.calamares.appdata.xml New upstream version 3.2.15 před 1 rokem
settings.conf Upstream release v3.2.9 před 1 rokem

README.md

Calamares: Distribution-Independent Installer Framework


GitHub release Build Status Travis Build Status Coverity Scan Build Status GitHub license

Report a Bug Contribute Translate Freenode (IRC): #calamares Wiki

Dependencies

Main:

  • Compiler with C++14 support: GCC >= 5 or Clang >= 3.5.1
  • CMake >= 3.3
  • Qt >= 5.9
  • yaml-cpp >= 0.5.1
  • Python >= 3.3 (required for some modules)
  • Boost.Python >= 1.55.0 (required for some modules)
  • KDE extra-cmake-modules >= 5.18 (recommended; required for some modules; required for some tests)
  • KDE Frameworks KCoreAddons (>= 5.58 recommended)
  • PythonQt (optional, deprecated)

Modules:

  • Individual modules may have their own requirements; these are listed in CMake output. Particular requirements (not complete):
  • fsresizer KPMCore >= 3.3
  • partition KPMCore >= 3.3
  • users LibPWQuality (optional)

Building

See wiki for up to date building and deployment instructions.