Calamares - distribution indipendent installer
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
Alf Gaida 41e04dc1d6 Update upstream source from tag 'upstream/3.2.15' 11 months ago
3rdparty New upstream version 3.2.15 11 months ago
CMakeModules New upstream version 3.2.15 11 months ago
LICENSES New upstream version 3.2.15 11 months ago
ci New upstream version 3.2.15 11 months ago
data New upstream version 3.2.15 11 months ago
debian Some changes for new version 11 months ago
lang New upstream version 3.2.15 11 months ago
man New snapshot: 3.2.2v3.2.2-1 2 years ago
src New upstream version 3.2.15 11 months ago
.clang-format New upstream version 3.2.15 11 months ago
AUTHORS Upstream release v3.2.9 1 year ago
CHANGES New upstream version 3.2.15 11 months ago
CMakeLists.txt New upstream version 3.2.15 11 months ago
CalamaresBuildTreeSettings.cmake.in New snapshot: 3.2.2v3.2.2-1 2 years ago
CalamaresConfig.cmake.in New snapshot: 3.2.2v3.2.2-1 2 years ago
CalamaresConfigVersion.cmake.in New snapshot: 3.2.2v3.2.2-1 2 years ago
CalamaresUse.cmake.in New snapshot: 3.2.2v3.2.2-1 2 years ago
Dockerfile New snapshot: 3.2.2v3.2.2-1 2 years ago
LICENSE New snapshot: 3.2.2v3.2.2-1 2 years ago
README.md New upstream version 3.2.15 11 months ago
calamares.desktop New upstream version 3.2.15 11 months ago
calamares.desktop.in New upstream version 3.2.15 11 months ago
cmake_uninstall.cmake.in New snapshot: 3.2.2v3.2.2-1 2 years ago
com.github.calamares.calamares.policy New snapshot: 3.2.2v3.2.2-1 2 years ago
io.calamares.calamares.appdata.xml New upstream version 3.2.15 11 months ago
settings.conf Upstream release v3.2.9 1 year ago

README.md

Calamares: Distribution-Independent Installer Framework


GitHub release Build Status Travis Build Status Coverity Scan Build Status GitHub license

Report a Bug Contribute Translate Freenode (IRC): #calamares Wiki

Dependencies

Main:

  • Compiler with C++14 support: GCC >= 5 or Clang >= 3.5.1
  • CMake >= 3.3
  • Qt >= 5.9
  • yaml-cpp >= 0.5.1
  • Python >= 3.3 (required for some modules)
  • Boost.Python >= 1.55.0 (required for some modules)
  • KDE extra-cmake-modules >= 5.18 (recommended; required for some modules; required for some tests)
  • KDE Frameworks KCoreAddons (>= 5.58 recommended)
  • PythonQt (optional, deprecated)

Modules:

  • Individual modules may have their own requirements; these are listed in CMake output. Particular requirements (not complete):
  • fsresizer KPMCore >= 3.3
  • partition KPMCore >= 3.3
  • users LibPWQuality (optional)

Building

See wiki for up to date building and deployment instructions.